ルーターのコマンド

ルーターのコマンド

スタティックルーティング

  1. ルーターのポートにIPアドレスを設定する
    Router(config)#interface g0/0
    Router(config-if)#ip address 192.168.1.254 255.255.255.0
    Router(config-if)#no shutdown
  2. スタティックルートの設定
    Router(config)#ip route [宛先ネットワーク] [サブネットマスク] [ネクストホップまたは出力インターフェース]
    
    Router(config)#ip route 192.168.10.0 255.255.255.0 192.168.2.254
    または
    Router(config)#ip route 192.168.10.0 255.255.255.0 g0/1
  3. デフォルトルートの設定
    Router(config)#ip route 0.0.0.0 0.0.0.0 [ネクストホップ]

    デフォルトルートとは「0.0.0.0/0」で全てのネットワークを示しており、ルーティングテーブルに無くても指定したネクストホップアドレスにパケットを転送してくれる便利で特別なルート。

ダイナミックルーティング

  • RIPの設定
    Router(config)#router rip
    Router(config-router)#version 2 (RIPv2にする場合)
    Router(config-router)#network 192.168.1.0
    Router(config-router)#network 192.168.2.0

    基本的にバージョンは揃えておかないとうまく動かないので注意すること

  • OSPFの設定
    Router(config)#router ospf [プロセスID]
    Router(config-router)#network [ネットワークアドレス] [ワイルドカードマスク] area [エリアID]
    
    Router(config)#router ospf 1
    Router(config-router)#network 192.168.1.0 0.0.0.255 area 0
    Router(config-router)#network 192.168.2.0 0.0.0.255 area 0

    プロセスIDは「1」から始まる
    エリアIDは「0」から始まって、エリア0に隣接していないと基本動かない。

  • EIGRPの設定
    outer(config)#router eigrp [AS番号]
    Router(config-router)#network [ネットワークアドレス] [ワイルドカードマスク]
    
    Router(config)#router eigrp 1
    Router(config-router)#network 192.168.1.0 0.0.0.255
    Router(config-router)#network 192.168.2.0 0.0.0.255

    AS(自律システム)番号は「1」から始まり、ネイバールータと同じ値にする必要がある。


トラブルが発生した場合はすぐにお電話(050-5532-9970)ください。
迅速なトラブル解決だけでなく、パソコン購入アドバイスもしております。

パソコンレスキュー
三鷹市周辺のパソコン修理・トラブル解決ならお任せください!

返信を残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA