VLANの設定

VLANの設定

VLANについて

VLAN(Virtual LAN)とは、物理的な接続形態とは独立して仮想的なLANセグメントを作る技術のことです。
VLANはスイッチ内部で論理的にLANセグメントを分割するために使用されます。
VLANを使用することでルータやL3スイッチと同じようにL2スイッチでもブロードキャストドメインの分割を行うことができます。

VLANの特徴

  1. ブロードキャストドメインの分割
  2. 物理配置にとらわれないセグメント化
  3. セキュリティの向上

VLANの使用方法

  1. VLANの作成
    Swich(config)#vlan [VLAN-ID]
    Swich(config-vlan)#name [VLAN-NAME]
  2. スイッチポートの設定
    Swich(config)#interface vlan 1
    Swich(config-if)#switchport mode [access|trunk|dynamic desirable|dynamic auto]

    DTP(Dynamic Trunking Protocol)は、スイッチポートをアクセスポートまたはトランクポートにするのかを動的に決定するシスコ社独自のプロトコルです。
    一般的にDTPは使用しないので、DTP送信停止を設定しておきます。

    Swich(config-if)#switchport nonegotiate
  3. アクセスポートに設定する場合
    Swich(config-if)#switchport mode access
    Swich(config-if)#switchport access vlan [VLAN-ID]
  4. トランクポートに設定する場合
    Swich(config-if)#switchport mode trunk
    
    ▼トランキングプロトコルの指定が必要な場合は先に指定する
    Swich(config-if)#switchport trunk encapsulation dot1q
  • ネイティブVLANの設定(デフォルトはVLAN1)
    Swich(config-if)#switchport trunk native vlan [VLAN-ID]
  • allowed VLANの設定
    トランクポートで転送を許可するVLANトラフィックを定義するためのコマンド
    Swich(config-if)#switchport trunk allowed vlan [引数] [VLAN-ID]
    
    
    ▼引数の種類
    add
    転送を許可したいVLANを追加する
    remove
    転送を許可しているVLANを削除する
    all
    全てのVLANの転送を許可する

VLANの設定状態の確認

  1. VLANの確認
    Switch#show vlan [brief]

    「show vlan brief」の方が表示が簡潔なので見やすい。

  2. 特定のスイッチポートのVLAN情報の確認
    Switch#show interfaces [インターフェースID] switchport
  3. 特定のトランクポートのVLAN情報の確認
    Switch#show interfaces [インターフェースID] trunk

トラブルが発生した場合はすぐにお電話(050-5532-9970)ください。
迅速なトラブル解決だけでなく、パソコン購入アドバイスもしております。

パソコンレスキュー
三鷹市周辺のパソコン修理・トラブル解決ならお任せください!

返信を残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA